Current Lua downloadable firmware will be posted here

User avatar
By mKotek
#29091 I have ESP-01 that I bought on Aliexpress. I have tried to install nodemcu on this board using flasher and it detects the board and uploads the firmware succesfully. Unfortunately, after reboot, I am getting garbage and MEM CHECK FAIL message instead of expected result.
When looking at 74800 connection speed I can see boot, but there is no ready message and I cannot access the board using ESPLORER or LUA UPLOADER. ESPLORER says it has connected but cannot detect firmware version. After trying flashing using different versions of nodemcu firmware I have uploaded sketch using Arduino IDE and it works fine.

Thinking, it might be related to a specific item, I have ordered another ESP-01 module, from different seller and the situation is exactly the same - I can run any sketch from Arduino IDE and it works, but when loading nodemcu, the upload is succesful, but after reboot or reset I cannot access the firmware and I am getting garbage and MEM CHECK FAILED message and ESPLORER is not able to perform any operation on the board.

Do you have any idea, what might be wrong or why nodemcu firmware does not work as expected, whereas Arduino IDE and AT firmware is working fine?
User avatar
By pzw
#29525 Check what kind of flash is installed at the module. On my modules they are 25Q40 chips. The Nodemcu flasher program uses for some reason default the DIO option. For 25Q40 chips you need to use the QIO option. (Double or Quad) . Make sure the speed is set to 40MHz and try again.
User avatar
By flagtrax
#29529 These things do seem to be a bit quirky. Note my post from earlier today. I did finally get the ESP-7 to take a flash, but I'll be darned if I know why. In desperation, I kept changing baud rates, and versions of nodemcu. When I first successfully flashed the module I flashed it with the version that was in the flasher. It was suggested on one of the YouTube tutorials to get the latest from github. So I originally downloaded the floating point version and tried to flash it when I reflashed and had problems. I then tried to load the integer version, and had problems with that too. Then I tried to load the original in the flasher again.....Batting 0! I finally went back to attempting the floating point version and kept trying different baud rates. finally I configured the flasher to "default" values, the only thing changing was the baud rate to 230400, and it flashed. I can now communicate using Esplorer. Other terminal programs I'm truthfully not sure of. To be honest I haven't learned enough yet to totally understand the communication methods, and how to talk to nodemcu. I'd like to persue this more, but since this is the only working module I have until more arrive, I hesitate to try flashing again. When my ESP12's get here, the fun will start all over, I'm sure. In the meantime, picking up little bits of obscure information like that offered by pzw helps a lot, thanks for that "pzw". At some point I hope all the needed information becomes more available, and more easily accessable.
User avatar
By pzw
#29536 Another tip;
When you have a new module, with the original firmware, then first hook it up to a terminal program, and read the output of the "AT+RST" command. If you have the "Ai-Thinker" firmware, it will tell you what the size / speed / mode of the flash chip is. Something like this:
Code: Select allAT+RST


 ets Jan  8 2013,rst cause:4, boot mode:(3,7)

wdt reset
load 0x40100000, len 816, room 16
tail 0
chksum 0x8d
load 0x3ffe8000, len 788, room 8
tail 12
chksum 0xcf
ho 0 tail 12 room 4
load 0x3ffe8314, len 288, room 12
tail 4
chksum 0xcf
csum 0xcf

2nd boot version : 1.2
  SPI Speed      : 40MHz
  SPI Mode       : QIO
  SPI Flash Size : 4Mbit
jump to run user1

Ai-Thinker Technology Co. Ltd.


AT version:
SDK version:0.9.5


This way you can figure out what size your flash chip is, and how to configure it in the flash tool(s).
Good luck.