Use this forum to chat about hardware specific topics for the ESP8266 (peripherals, memory, clocks, JTAG, programming)

User avatar
By alex_g
#64764 (A few days later still...)

I'm sure I have found the reason why the ESP-01 wouldn't flash on the Witty base, whereas the ESP-07 will.
The ESP-07 breakout board comes with a 10k pull-up resistor to CH_PD (EN) as well as a 10k pull-down to GPIO15. Now, ESP-01 doesn't use GPIO15, but certainly uses CH_PD, like all ESPs do!

The little USB stick thing that I use for programming ESP-01s obviously has this built in already but I am guessing that the Witty base does not, because it lives on the top board, just as it does for the ESP-07 breakout. Which explains why I could program my ESP-01s on the USB sticks but not on the Witty base. (Although note that you still do have to pull down GPIO0 when flashing the ESP-01 on the USB stick - not so on the Witty base, of course, as that does the DTR/RTS trick for you automatically)

The above dawned on me when I found that even though my ESP-01s worked perfectly when run off the USB-stick, they would not work when removed and run standalone. The addition of a 10k between CH_PD and 3v3 solved that problem!

I am practically certain that was the cause! I haven't got time to test it right now, but I will soon be making a "breakout-breakout" board for the ESP-01, to allow it to be plugged in to the Witty base. The USB stick, even though it works great, is quite fiddly, whereas the Witty base is extremely handy for me (ymmv).

Another thing to remember is that on the ESP-01 you have to cross the TX and RX lines, they are not straight through connections as in the case of the ESP-07 form factor.

User avatar
By bobstro
alex_g wrote:[...] I'll put up some pics of my program-flashing setup and the "breakout-breakout" board if anyone is interested.

I'd be very interested in any details you can provide. I'm still very new to the ESP8266 and have been struggling with how to program bare modules. I've got 2 of the Witty boards, and was hoping to be able to do something like this with them. Any info very much appreciated!
User avatar
By alex_g
#64805 Right, no progress I'm afraid.
I made up a little breakout board for programming the ESP-01 on the Witty base (since that would be more convenient for me than using the USB stick thingummy). It doesn't seem to work at all.
Here's what I did: (Wiity base pins on left, ESP-01 pins on right)
5v - to 1117 converter and then to ESP - 3v3
RST - RST (seems to work, chip does reset when Witty button is pressed)
CH_PD - CH_PD (AND I have pulled this high via a 10k)
GPIO0 - GPIO0 (left floating, though I tried grounding it, too. Witty should take care of this)
GPIO2 - GPIO2 (left floating, though I tried pulling it high via 10k, too)
RXD - TXD } If connect them straight through, (as on ESP07) it doesn't seem to do much...

I wonder what I'm doing wrong? ESP-01s still work fine with the USB stick thingummy, so I haven't blown them! Also the Witty base still continues to work fine with the Witty, and with the ESP-07 breakout boards, so I haven't blown that either :D


Hi bobstro, what chip are you trying to program with the Witty base?
As I said before, those with the ESP-07 breakout format work just fine with the Witty, pins go straight through, just like the Witty topboard. (Although you must adjust for voltage - remove the little shunt and add a regulator chip.

I would not use the ESP-05 again (yes, I know I am messing around with it) as I found that it has almost double the power consumption of the ESP-07. It may be they have an old ROM, who knows, but my milliammeter doesn't lie (much).

If you must use those USB stick thingummies for an ESP-05, I found you still have to ground GPIO0 in order to flash it, other than that it's fine.


PS. I just found martinayotte's post a couple of pages back that says both GPIO0 and GPI02 must be pulled high for boot execution to work. I'll give that a try...
I am a bit perplexed, though, I found that if I want to flash the chip I have to ground GPIO0.
PPS. Nah, that didn't work either, neither via a 10k nor straight to 3v3. Back to the old USB thingummy it is, then :(