So you're a Noob? Post your questions here until you graduate! Don't be shy.
User avatar
By Davidthe 16
#65095 Hello.
I'm trying to compile a project with esp_iot_sdk 1.30
but I get "esptool: Permission denied" every time I hit make.
Code: Select alldavid@david-VirtualBox:~/myprojects/esp8266-injection-example$ ls -al
total 36
drwxrwxr-x  7 david david 4096 אפר 24 20:40 .
drwxrwxr-x  6 david david 4096 אפר 20 19:38 ..
drwxrwxr-x  2 david david 4096 אפר 20 16:51 driver
drwxrwxr-x 12 david david 4096 אפר 24 20:40 esp_iot_sdk_v1.3.0
drwxrwxr-x  8 david david 4096 אפר 20 16:51 .git
drwxrwxr-x  3 david david 4096 אפר 20 16:51 include
-rw-rw-r--  1 david david 4069 אפר 20 19:44 Makefile
-rw-rw-r--  1 david david  597 אפר 20 16:51
drwxrwxr-x  2 david david 4096 אפר 20 16:51 user
david@david-VirtualBox:~/myprojects/esp8266-injection-example$ sudo make clean
david@david-VirtualBox:~/myprojects/esp8266-injection-example$ sudo make
CC driver/uart.c
CC user/user_main.c
AR build/app_app.a
LD build/app.out
FW firmware/0x00000.bin
/bin/sh: 1: /home/david/myprojects/esptool: Permission denied
Makefile:109: recipe for target 'firmware/0x00000.bin' failed
make: *** [firmware/0x00000.bin] Error 126

I'm using esp-open sdk.
I downloaded esptool from here : (according to step 2 here: and made that my FW_TOOL

I'm tying to compile this project :

I tried this solution but it didn't work (I tried to do it for the esptool folder in esp-open-sdk, and for the esptool folder I downloaded above) viewtopic.php?p=12465

I tried to do sudo chmod 777 esptool, for both esptool folders

And nothing works for me :( :evil:

Please help!

Here is my Makefile:

Code: Select alldavid@david-VirtualBox:~/myprojects/esp8266-injection-example$ cat Makefile
# tnx to mamalala
# Changelog
# Changed the variables to include the header file directory
# Added global var for the XTENSA tool root
# This make file still needs some work.
# Output directors to store intermediate compiled files
# relative to the project directory
BUILD_BASE      = build
FW_BASE         = firmware

# Base directory for the compiler
XTENSA_TOOLS_ROOT ?= ~/myprojects/esp-open-sdk/xtensa-lx106-elf/bin

# base directory of the ESP8266 SDK package, absolute
SDK_BASE        ?= $(CURDIR)/esp_iot_sdk_v1.3.0 path and port
ESPTOOL         ?= ~/myprojects/esp-open-sdk/esptool/
ESPPORT         ?= /dev/ttyUSB0

# name for the target project
TARGET          = app

# which modules (subdirectories) of the project to include in compiling
MODULES         = driver user
EXTRA_INCDIR    = include ~/myprojects/esp-open-sdk/xtensa-lx106-elf/include

# libraries used in this project, mainly provided by the SDK
LIBS            = c gcc hal pp phy net80211 lwip wpa main

# compiler flags using during compilation of source files
CFLAGS          = -Os -g -O2 -Wpointer-arith -Wundef -Werror -Wl,-EL -fno-inline-functions -nostdlib -mlongcalls -mtext-section-literals  -D__ets__ -DICACHE_FLASH

# linker flags used to generate the main object file
LDFLAGS         = -nostdlib -Wl,--no-check-sections -u call_user_start -Wl,-static

# linker script used for the above linkier step
LD_SCRIPT       =

# various paths from the SDK used in this project
SDK_LIBDIR      = lib
SDK_LDDIR       = ld
SDK_INCDIR      = include include/json

# we create two different files for uploading into the flash
# these are the names and options to generate them
FW_FILE_1       = 0x00000
FW_FILE_1_ARGS  = -bo $@ -bs .text -bs .data -bs .rodata -bc -ec
FW_FILE_2       = 0x40000
FW_FILE_2_ARGS  = -es .irom0.text $@ -ec

# select which tools to use as compiler, librarian and linker
CC              := $(XTENSA_TOOLS_ROOT)/xtensa-lx106-elf-gcc
AR              := $(XTENSA_TOOLS_ROOT)/xtensa-lx106-elf-ar
LD              := $(XTENSA_TOOLS_ROOT)/xtensa-lx106-elf-gcc

#### no user configurable options below here
FW_TOOL         ?= ~/myprojects/esptool
SRC_DIR         := $(MODULES)
BUILD_DIR       := $(addprefix $(BUILD_BASE)/,$(MODULES))

SDK_LIBDIR      := $(addprefix $(SDK_BASE)/,$(SDK_LIBDIR))
SDK_INCDIR      := $(addprefix -I$(SDK_BASE)/,$(SDK_INCDIR))

SRC             := $(foreach sdir,$(SRC_DIR),$(wildcard $(sdir)/*.c))
OBJ             := $(patsubst %.c,$(BUILD_BASE)/%.o,$(SRC))
LIBS            := $(addprefix -l,$(LIBS))
APP_AR          := $(addprefix $(BUILD_BASE)/,$(TARGET)_app.a)
TARGET_OUT      := $(addprefix $(BUILD_BASE)/,$(TARGET).out)

LD_SCRIPT       := $(addprefix -T$(SDK_BASE)/$(SDK_LDDIR)/,$(LD_SCRIPT))

INCDIR  := $(addprefix -I,$(SRC_DIR))
EXTRA_INCDIR    := $(addprefix -I,$(EXTRA_INCDIR))
MODULE_INCDIR   := $(addsuffix /include,$(INCDIR))

FW_FILE_1       := $(addprefix $(FW_BASE)/,$(FW_FILE_1).bin)
FW_FILE_2       := $(addprefix $(FW_BASE)/,$(FW_FILE_2).bin)

ifeq ("$(V)","1")
Q :=
vecho := @true
Q := @
vecho := @echo

vpath %.c $(SRC_DIR)

define compile-objects
$1/%.o: %.c
        $(vecho) "CC $$<"
        $(Q) $(CC) $(INCDIR) $(MODULE_INCDIR) $(EXTRA_INCDIR) $(SDK_INCDIR) $(CFLAGS)  -c $$< -o $$@

.PHONY: all checkdirs flash clean

all: checkdirs $(TARGET_OUT) $(FW_FILE_1) $(FW_FILE_2)

        $(vecho) "FW $@"
        $(Q) $(FW_TOOL) -eo $(TARGET_OUT) $(FW_FILE_1_ARGS)

        $(vecho) "FW $@"
        $(Q) $(FW_TOOL) -eo $(TARGET_OUT) $(FW_FILE_2_ARGS)

        $(vecho) "LD $@"
        $(Q) $(LD) -L$(SDK_LIBDIR) $(LD_SCRIPT) $(LDFLAGS) -Wl,--start-group $(LIBS) $(APP_AR) -Wl,--end-group -o $@

$(APP_AR): $(OBJ)
        $(vecho) "AR $@"
        $(Q) $(AR) cru $@ $^

checkdirs: $(BUILD_DIR) $(FW_BASE)

        $(Q) mkdir -p $@

        $(Q) mkdir -p $@

flash: firmware/0x00000.bin firmware/0x40000.bin
        -$(ESPTOOL) --port $(ESPPORT) write_flash 0x00000 firmware/0x00000.bin 0x40000 firmware/0x40000.bin

        $(Q) rm -f $(APP_AR)
        $(Q) rm -f $(TARGET_OUT)
        $(Q) rm -rf $(BUILD_DIR)
        $(Q) rm -rf $(BUILD_BASE)

        $(Q) rm -f $(FW_FILE_1)
        $(Q) rm -f $(FW_FILE_2)
        $(Q) rm -rf $(FW_BASE)
Last edited by Davidthe 16 on Mon Apr 24, 2017 12:51 pm, edited 1 time in total.
User avatar
By Davidthe 16
#65222 no, I am part of that group, and I have esp826.

Note: I can burn 'blink' project on my esp. Apparently there is a problem with this sdk (?)

Code: Select alldavid@david-VirtualBox:~/myprojects/esp8266-injection-example$ lsusb
Bus 001 Device 003: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter
Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
david@david-VirtualBox:~/myprojects/esp8266-injection-example$ ls -al /dev/ttyUSB0
crw-rw---- 1 root dialout 188, 0 אפר 24 20:20 /dev/ttyUSB0
david@david-VirtualBox:~/myprojects/esp8266-injection-example$ groups
david adm dialout cdrom sudo dip plugdev lpadmin sambashare

Last edited by Davidthe 16 on Mon Apr 24, 2017 12:41 pm, edited 1 time in total.