So you're a Noob? Post your questions here until you graduate! Don't be shy.
User avatar
By liderbug
#69968 My 8266 is the one with the USB, Rst&Flash buttons.

So I've got my 8266 usb'ed to my RasPi. I can run Arduino IDE, load Blink, upload...
setting timeout 1
setting char tim...1
espcomm_send... 2 bytes
writing flash
.............(lots of blinking) nauseam...
starting app without reboot
espcomm_send... header
espcomm_send payload
espcomm_sen .. rec 2 bytes
closing bootloader
and here I sit - no blink, no anything ...
so I ran the set IP to 192, 168, 0, 32 ssid="xxxxx" pass="yyyyy", upload
runs, I get the same output as above, just sits there and ping 198..32 - not there
The orig IP is gone also - my server doesn't see the WiFi. Although the blue led blinks about every 8 seconds...

Thanks for any help - and I will keep pounding forehead against screen...
User avatar
By schufti
#69969 Hi,
regarding blink:

make sure you
°) used the correct "blink", the one for ESP8266 (files,examples,ESP8266,Blink) see comment at top of code
°) set your board to NodeMCU V1.0 (Tools,board,...)
this should get you going...
User avatar
By liderbug
#69973 generic esp8266 module
flash mode: DIO
debug port serial ................ where do I view?
reset modemcu .................... how do I "factory reset?"
speed 114200
port ttyUSB1
get board info: BN: Unknown board, 10c4, ea60, sn=upload any to obtain

So last night (are you ever coming to bed :evil: ) I did get some things to work - althought I'm not sure how or why. I loaded someone's "Hello_World" (ssid) and my server saw it but wouldn't connect. Let me back up a bit. This all started with a RasPi post (my hot tub some times goes wonky - I go out needing a good hot soak and ^^$#^#^&%&%& 90 or less deg F) Sounded like the perfect soultion and here we are. And I'm a geek, luv a challenge, I'm KCOBLACK1, RasPi controlled hydroponic greenhouse.

I did find out - after uploading something last night I tried hooking up the TMP36 - put the wire in to D0 and the blue led just off the Rst button (OH there it is) dimly blinking and fast (?100/sec) and the blue led on the WiFi chip came on :o connected the Gnd and 3.3v and board led on solid. Removed wires and nothing changed - until I did another Upload - assume "resetting board". Oh, code says "Serial.print (attempting to connect..." where does that show up?

So I'm thinking ... load code, do Upload, when done - I hit the Flash button? Pull up/down GPIO pin X? Rst? It's like I've got a blindfold on. I'm so close but ??????
Thanks for instructions.