So you're a Noob? Post your questions here until you graduate! Don't be shy.

User avatar
By IndonesiaIOT
#79308 Hello, newbie here.

Started this soil moisture sensor project and this actually my first time.

Yesterday I was stuck with the problem of connecting ftdi to the sparkfun esp8266 and after searching on google then I found the solution which is connecting the jumper on the back side of the sparkfun esp8266.

Now, I face another problem with uploading the script to esp8266 board.

I want to check if every components in my projects works well by uploading this script ;

#define ESP8266_LED 5

void setup ()
pinMode(ESP8266_LED, OUTPUT);

void loop ()
digitalWrite (ESP8266_LED, HIGH);
digitalWrite (ESP8266_LED, LOW);

The port for my ftdi is on COM5.

And then I get this reply message :

Arduino: 1.8.7 (Windows 10), Board: "SparkFun ESP8266 Thing, 80 MHz, Flash, 512K (no SPIFFS), v2 Lower Memory, Disabled, None, Only Sketch, 57600"

Sketch uses 247932 bytes (49%) of program storage space. Maximum is 499696 bytes.
Global variables use 28012 bytes (34%) of dynamic memory, leaving 53908 bytes for local variables. Maximum is 81920 bytes.
warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

it would be great if any of you experts can tell me what's wrong. Thanks before
Last edited by IndonesiaIOT on Tue Dec 11, 2018 8:21 am, edited 1 time in total.
User avatar
By IndonesiaIOT
#79357 Hi everyone,

After searching here and there,

I found this message from the port terminal :

ets Jan 8 2013,rst cause:2, boot mode:(3,6)

load 0x4010f000, len 1264, room 16
tail 0
chksum 0x42
csum 0x42

I searched what does that mean and it stated that the number 3 indicates that pins GPIO2 and GPIO0 are set HIGH and GPIO15 is set LOW. This is configuration for normal operation of module (to execute application from flash), not for boot loading (flash programming).

The question is, how to change the boot mode to number 1 so only the GPIO2 generate 3.3V? Then it will become UART not Flash.
User avatar
By IndonesiaIOT
wattuasca wrote:Hi,

I'm in the same boat right now...

Have you tried to install ... uartb-LJMf and read ... ailed.html ?

Hi, thank you for replying. Thank you for the reference, I've installed the CP210x and read through the article.

The article actually helps me know where the mistake is, it is on the FTDI. Because when I try doing the serial test the RX TX is actually faulty. So this lead me to buy a new FTDI 232 with a jumper switch from 3.3V to 5V with ease.

I installed the CP210x and I did not know what kind of effect it will make to my esp8266 board but the Arduino IDE did not recognize my board as esp8266. So I change it to Generic ESP8266 module and try uploading the same script above.

Voila! It WORKS! the number 5 LED on my sparkfun esp8266 is blinking!

Thank you for helping me solved this problem.