Chat freely about anything...

User avatar
By eriksl
#81794 BTW I checked it out, enabling dio mode will cost 644 bytes of IRAM. I have that available, but I'd rather not sacrifice it for this purpose.
User avatar
By holopaul
#81821 Thanks for all the pointers, but I've been at it for the last 12 hours without any success. I think i'm losing it a bit. :shock:
I read all the documentation about the flash modes.
I can tell you the following:
-I'm using ESP12F module with espressif logo not AI
-The esptool flash_id output is this :
Manufacturer: 20
Device: 4016
Detected flash size: 4MB
-esptool.py version 2.6
-About the flash size in esptool v2.6 the bit parameter was replaced with byte (32mb = 4MB)
-For the previous releases I had no problem with the parameters -fs 2MB-c1 -fm dio . Also v20 is working fine with -fs 4MB -fm qio
-I'm using rboot-config.bin found in the Release 17
-com port output 74880 baud for -fs 4MB -fm qio
Code: Select allets Jan  8 2013,rst cause:1, boot mode:(3,7)

load 0x40100000, len 1628, room 16
tail 12
chksum 0xb8
ho 0 tail 12 room 4
load 0x3ffe8000, len 704, room 12
tail 4
chksum 0x90
csum 0x90

rBoot v1.4.2 - richardaburton@gmail.com
Flash Size:   32 Mbit
Flash Mode:   QIO
Flash Speed:  40 MHz
rBoot Option: Big flash
rBoot Option: RTC data

Booting rom 0 at 2000, load addr 599e0.
sy�


thanks
User avatar
By holopaul
#81826 Can the new version of esptool i'm using be the cause? I will try to revert to previous version and give it a try. What version are you using ?
User avatar
By eriksl
#81837 I don't so, but I think I am using a very old version. I am using the ".py" version I am not sure if it even has a version. It says:
Code: Select allesptool.py v1.2-dev - ESP8266 ROM Bootloader Utility


If you own a "normal" ESP12E/F/S, it's really qio (all data lines connected), so you shouldn't specify dio.

For flashing it doesn't matter what baud rate you're using. The ESP can autodetect up to about 2 Mbaud, but I found it's not useful to use anything higher than 1 Mbaud because the flash isn't written any quicker than that. Also at these speeds, the wiring becomes very critical. But I'd try 1 Mbps at least and if it doesn't (flashing errors) halve it until it works.

When you flash the espiobridge image, you should also flash the rboot code that comes with it, I think you're already doing that (from your earlier code). The rboot config should not need update, but it doesn't hurt, so as long as it doesn't work, I'd also flash that section.

If you didn't specify GPIO1 as "UART" in your config, the UART output won't be enabled and you won't see anything (exactly as you're experiencing now). There are two ways to get around this (omission, I now see):
- make a config sector like this and write it (using esptool(.py) to 0x7a000 (plain image) or 0xfa000 (ota image) and please note the empty line at the end. This will enable the UART output.
Code: Select all%4afc0002%
wlan.mode=0
wlan.client.ssid=xxxxxxxxxx
wlan.client.passwd=xxxxxxxxxxx
io.0.1.mode=8
io.0.1.llmode=7


- or wait a few days, then I will make a new release that will have the new code active where the UART is always enabled when I/O 0/1 isn't explicitly enabled for something else.

Don't give up, we'll sort this. But I think you'll have to have patience a few days yet ;-)