Downloading and installing the new Arduino IDE for ESP8266

Moderator: igrr

User avatar
By Chris-2016
#82267 Just downloaded Arduino Version 1.8.9 and am using Files --> Preferences and adding "" to the "Additional Boards Manager URLs:"

When going to the Board Manager, "esp8266 by esp8266 community" does not show up in the list ?

What happened to it as I need it and how to fix?

User avatar
By QuickFix
#82275 You'll have to restart the Arduino IDE (that's: really close and start it), before the link is retrieved.
If that doesn't work: install the ESP-core manually (just follow the instructions for Git).
User avatar
By Serguey
#88577 I get exactly the same problem.
I have added the required URL ( ... index.json) into the Additional Board Manager URLs list, restarted the IDE, but library "ESP8266 by ESP8266 community" does not show in the Library Manager list.

I downloaded library "ESP8266 core for Arduino" from here:, and tried to install it manually. However, when trying to install the ZIP library (Sketch - Include Library - Add .ZIP Library), I get this error message:

Arduino: 1.8.10 (Windows 7), Board: "Generic ESP8266 Module, 80 MHz, Flash, Legacy (new can return nullptr), All SSL ciphers (most compatible), dtr (aka nodemcu), 26 MHz, 40MHz, DOUT (compatible), 1MB (FS:64KB OTA:~470KB), 2, nonos-sdk 2.2.1+100 (190703), v2 Lower Memory, Disabled, None, Only Sketch, 115200"

Specified folder/zip file does not contain a valid library

I tried to copy the unzipped folded into the Library folder. However, when opening the Library Manager, I get this message in the Arduino IDE console:

Invalid library found in C:\Program Files (x86)\Arduino\libraries\esp8266-2.7.4: no headers files (.h) found in C:\Program Files (x86)\Arduino\libraries\esp8266-2.7.4

What's the problem with this library?