Your new topic does not fit any of the above??? Check first. Then post here. Thanks.

Moderator: igrr

User avatar
By josephchrzempiec
#83107 Thank you Rudy. My plan is to connect it to the network and be online. It is just to mostly have a profile of my self with a couple of pictures and some text. It's mostly to learn and have some fun. Plus sharing with others what i have learn is the best part of all.

User avatar
By josephchrzempiec
#83111 Hello Rudy i have the link and I uploaded it but i can a page that say FileNotFound. I have tried the other links and it keep going i need another library after another. So i did that and got all libraries then i got a error saying one of the files from the library can't be found but i know its there and i can see it.

For the first link I'm not sure what am i doing wrong. I don't understand. Can you please help me?

User avatar
By Sirquil
#83112 I have a project that creates two web site from one sketch. Both use dynamic web pages; one being ESP8266 based and one on a hosted domain.

Project web sites:

Hosted Domain website

ESP8266 Based web site

Project code is attached; hosted domain web site has had over 1500 visitors, some from around the world. I use service to log users geographical information.
You do not have the required permissions to view the files attached to this post.
User avatar
By rudy
josephchrzempiec wrote:Hello Rudy i have the link and I uploaded it but i can a page that say FileNotFound.

I don't have all the other libraries for the other library to work so I am using the above. There are two things that need to be done. The FSBrowser.ino program compiled and loaded, and the contents of the data folder loaded to the SPIFFS memory area of the flash chip on the ESP12.

In the Tools tab of the Arduino IDE there needs to be a selection called ESP8266 Sketch Data Upload just above the board selection section. That needs to be executed to transfer the files in the data area.

I tried it with my setup and I got an error saying that "ESPTOOL NOT FOUND!". It used to work but I am running a newer GIT version of the Arduino-ESP8266 code and things have changed. I needed to load a newer version of the upload tool. I found that at this link. ... -470147771

I extracted the file and replaced the file in my C:\Users\Rudy\Documents\Arduino\tools\ESP8266FS\tool folder. After that I was able to upload the contents of the C:\Users\Rudy\Documents\Arduino\esp8266\FSBrowser\data directory.

I was able to them run the code on the ESP module and get the web pages. The following is what got printed to the serial port on startup.

Code: Select allConnected! IP address:
Open http://esp8266fs.local/edit to see the file browser
HTTP server started
pm open,type:2 0
handleFileRead: /edit.htm
handleFileRead: /index.htm
handleFileList: /
handleFileRead: /favicon.ico
handleFileRead: /index
handleFileRead: /index.htm
handleFileRead: /graphs.js

I hope this helps. Let me know if there is anything that is unclear.