Use this forum to chat about hardware specific topics for the ESP8266 (peripherals, memory, clocks, JTAG, programming)

User avatar
By markdh102

I've been running an MQTT Arduino sketch with no problems. Connected to my router fine. Then yesterday it just wouldn't connect. Status is WL_DISCONNECTED after the WiFi.begin(). I've put a very simple example sketch back in and still no connection. It WILL connect to a hotspot created by my Android ( Sony Xperia X phone.
My router is odd in that it is a MIFI router and it doesn't come with much in the way of configuration options. Let alone a connection log. It is a Huawei R218h.
I should add that I have another Heltec Kit8 running exactly the same sketch and that connects fine.
I've tried various code suggestions but with no luck. Anyone ever seen anything similar?
Last edited by markdh102 on Tue Dec 10, 2019 4:20 am, edited 1 time in total.
User avatar
By markdh102
#84877 Ok, sort of solved. I had made a small veroboard circuit. Very simple. Just a 240VAC to 5VDC converter and an LED. Once I lifted the Heltec Kit 8 off the Veroboard it started connecting again. I plugged it into a breadboard and it stopped connecting again. I have since turned the Heltec around on my vero so that the antenna is away from the PSU and I've also removed all the copper track from the vero underneath the antenna.
I think that the WiFi is very weak on this board.