So you're a Noob? Post your questions here until you graduate! Don't be shy.

User avatar
By Ian Hamilton
#64965 1. ESP-01 (8mb)
2. Tried flashing with at NON-BOOT firmware from ESP8266_NONOS_SDK_V2.0.0_16_08_10
3. Built at example and tried flashing that
4. Built smart_config and tried flashing that
5. Fo building parameters were all defaulted except for SPI size and map where I selected 2 [1024KB (512KB + 512KB)]
All result in error from ESP-01

Fatal exception (28):
epc1=0x4000228b, epc2=0x00000000, epc3=0x00000000, excvaddr=0x000000b5, depc=0x00000000

continually scrolling output.

Running on Mac OS Sierra
Developing on downloaded VirtualBox image from espressif
Flashing on Mac OS Sierra using

I have tried erasing the flash using esptool first
I have verified using esptool that the flash is successful by using the verify_flash commend in esptool

I used the following map to burn the all the above flash images as per from SDK

eagle.flash.bin 0x00000
eagle.irom0text.bin 0x10000
blank.bin 0x7e000
blank.bin 0xfe000
esp_init_data_default.bin 0xfc000

esptool output was v1.3
Auto-detected Flash size: 8m
Running Cesanta flasher stub...
Flash params set to 0x0020
Wrote 45056 bytes at 0x0 in 3.9 seconds (91.6 kbit/s)...
Wrote 372736 bytes at 0x10000 in 32.3 seconds (92.2 kbit/s)...
Wrote 4096 bytes at 0x7e000 in 0.4 seconds (85.5 kbit/s)...
Wrote 4096 bytes at 0xfe000 in 0.4 seconds (85.4 kbit/s)...
Wrote 4096 bytes at 0xfc000 in 0.4 seconds (85.4 kbit/s)...

Clearly I have missed a step or misunderstood something.
Any help would be appreciated
User avatar
By OttoNP
#65382 I solved this by flashing using dout mode. I had 3 esp8266 with that error and on 2/3 I just flashed with dout mode but for one I had to run erase_flash first. This was using esptools....

I spent way too long figuring this out...
User avatar
By Pioterk
#84897 Just want to say thank you. Your post saved me a lot of hassle. I tried flashing Sonoff TH16 version 2.1 with Fatal exception (28) as the result. I checked memory chip and it was T25S80 - different then previous PN25F08. This is probably what required flashing mode change necessary.