Use this forum to chat about hardware specific topics for the ESP8266 (peripherals, memory, clocks, JTAG, programming)

User avatar
By ClemensESP
#87834 I received a D1 Mini board (after using some ESP Modules with UART cable, but I could use some more IO).

I immediatly flashed my sketch with the Arduino IDE, and this just worked.

Now I worked further on the sketch...and uploading isn't possible anymore, I always get

"esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header"

My guess is that because of the serial connection in the first sketch, it's busy now or idea.
I tried connecting D3 (GPIO0) to ground forcing programming mode (BLUE LED is off wenn doing this), but with no succes. I also tried pressing reset in different ways.

I also installed the USB driver...

Has someone any tips what I could try?

Thanks a lot!

Kind regars,
User avatar
By ClemensESP
#87838 I found a solution... But maybe someone has an idea why it is like that.

I'm now able to flash if I connect d3(gpio 0) to gnd and d4 (gpio 2) to 3.3v. I read that you need to do this to set the esp8266 in programming mode, thats why I tried it. However I did nowhere read someone needed to do this on their d1 mini, d3 to gnd seemed sufficient if programming wasn't possible automatically. It also doesn't matter what code is flashed, also for an empty sketch it only works if I connect the two pins like described.