Chat freely about anything...

User avatar
By hellraiser
#90072 Hi folks,

I am fighting with an issue I am not able to solve by myself even after days of googling and testing.

I am trying to put my ESP into deep sleep without satisfying result. So I have this traditional measure, send and sleep routine. After I execute machine.deepsleep() command my ESP is waking up for a random number of times. So it can send 15 measures over mqtt or 50 measures, no pattern at all.

I've obviously connected D0 with RST, I tried 2 differernt power banks and power supply with the same result.

What is strange, when ESP stops sending data it should be in deep sleep (last command in log) but I can access it via rshell (when connected to rpi3 usb port). So I am totally confused :/

Any help much appreciated.
User avatar
By schufti
#90122 for one thing I see, you are not in line with the randomnerdtutorial for deepsleep in µPython:
the example has "machine.deepsleep()" wherase you have "machine.deepsleep(msecs)"

so you maybe set up a wake event twice: once in lines 34-37 and second in line 41.
remark: for machine.deepsleep() a msec argument won't work as expected, it uses µsecs ...