Using the new Arduino IDE for ESP8266 and found bugs, report them here

Moderator: igrr

User avatar
By Schascho
#92163 I have the exact same issue and I didn't solve it yet but I can add one thing that might be of interest. I have Manjaro installed on my Laptop and PC. I installed the Arduino IDE on my Laptop a couple of months ago and right now on my PC. When trying to upload a sketch on my PC I got the same error you described and could not solve it, so I tried it on my laptop because I have uploaded sketches from it in the past and it worked fine. After that I performed an update of the Arduino IDE (because it was a couple of months old, as part of a system upgrade) and tried it again and got the same error so I suspect that a change in the arduino IDE caused the issue.

If anyone has any idea please let me know
Help is greatly appreciated
User avatar
By ironman977
#92595 I have the same issue, and I want to share a test I did. I tried with last arduino IDE on a Windows virtualbox virtual machine on the same USB port and with the same Nodemcu and I succesfully uploaded a firmware.

When I try the same thing on Linux (after Windows virtual machine shutdown) I got a timeout error, I think is something related to Linux version of esptool