So you're a Noob? Post your questions here until you graduate! Don't be shy.

User avatar
By u173487
#82891 Hi,

I am having trouble connecting to my d1 mini to install blink and run my very 1st program on an esp8266 board,

The chip does not appear to be listed in device manager under ports.
I have listed the devices attached via USB at the device level and I can not see anything there.
I have attempted to install CH341SER.INF drivers however I get the message "The drive is successfully pre-installed in advance!". When I go to uninstall I receive the message "No device is found!"

I suspect CH341SER is my problem however, I still can not see any 'Unknown Device' when i view my USB connections at the OS level.

Has anyone seen this problem before or had experience with potential driver problems? I have tried multiple USB cables, USB controllers, ports, etc and I get the same behaviour from within windows.

Many thanks in advance.
User avatar
By ed.kissack
#92658 I've recently bought 2 of these microcontrollers and had the same issue. Tried various leads, but this was a red herring as windows had recognised the USB device but it was not functioning. Further searches suggested 21xx driver (didn't help) and then the CH340 drivers. I found them here (referenced to, on another site) and straight away I could programmed the D1 via ESPHome.