Your new topic does not fit any of the above??? Check first. Then post here. Thanks.

Moderator: igrr

User avatar
By AManda58
Jack7 wrote:
AlexanderMason wrote:Hello, I've experienced a problem with the NodeMCU board. I have several esp8266 modules and a NodeMCU which I found more convenient for fast prototyping. I made a simple sketch that creates a soft AP, webserver and handles a simple HTML page with a couple of forms. After data is submitted into forms server esp8266 forwards acquired data through rs232 to regular Arduino Uno.
It's pointless to postcode because I've tried many variations and ended up with the same results.

Whenever I flash the esp8266 module everything works flawlessly. When I upload the same sketch into NodeMCU FM Whatsapp AP goes very glitchy, e.g. it drops the connection, won't allow me to connect, and whenever I manage to finally connect it sends cropped data to the browser. I choose the correct board type, however, I tried different boards and settings but nothing helps. I tried to power up it from separate lab PSU = same problems.
Probably there's something that needs to be done that I'm missing? Or it's simply a faulty chip?
Thanks in advance!

In case the code really works on one board, it should work on the other, too. To be entirely sure, you may want to use the code sample for AP with WEB server shipped with Arduino (or platform, whatever you use)

Thanks for the information, but I have already tried this once. And it hasn't given satisfactory solution.
User avatar
By Arshi
#95960 NodeMCU soft AP failure could be due to a variety of factors, including incorrect firmware version, incorrect provisioning of the SSD, and many more. [url=""][COLOR="#FFFFFF"]GBWhatsApp[/COLOR][/url]
User avatar
By Arshi
DIRR70 wrote:Hi Alexander,

GB WhatsAppIt really seems that your NodeMCU is fried. There's no difference for the code between a 'single" ESP8266 and the NodeMCU. In case the code really works on one board, it should work on the other, too. To be entirely sure, you may want to use the code sample for AP with WEB server shipped with arduino (or platformIO, whatever you use). The power supply on the NodeMCU is perfectly fine to serve the board for AP purposes. You can't do very much to change the behaviour, maybe except trying different variants of the lwIP. But if the other board works with your code and board settings, I would definitely test a new NodeMCU...

The comment suggests that the NodeMCU may be faulty and recommends testing the code with a different board to confirm. It also mentions that the power supply on the NodeMCU should be sufficient for AP purposes. Trying different lwIP variants may be an option, but getting a new NodeMCU is recommended if the code works on other boards.
User avatar
By davide8
#96212 If you are experiencing issues with the soft AP functionality of your NodeMCU module, there are a few things you can try:
1. Check the firmware version: Make sure that you are using a firmware version that supports soft AP mode. Some older versions of the firmware may not have this functionality.

2. Check the code: Double-check your code to ensure that you have correctly enabled the soft AP mode and that you have set up the necessary parameters, such as the SSID and password.

3. Check the power supply: Insufficient power supply voltage can cause the module to malfunction. Make sure that you are providing enough power to the module, and that the power supply is stable and reliable.

4. Check for interference: Wi-Fi signals can be disrupted by other sources of electromagnetic interference. Make sure that there are no sources of interference near the module, and that the antenna is correctly connected.

5. Try a different module: If none of the above steps resolve the issue, it is possible that the module itself is faulty. Try using a different module to see if the problem persists.

Thanks guys..