Use this forum to chat about hardware specific topics for the ESP8266 (peripherals, memory, clocks, JTAG, programming)

User avatar
By oZZyDev
#96261 Hello,
I'm using a WEMOS D1 Mini Pro with ADS1115, OLED 1.3", RTC and MicroSD module.
The circuit is soldered to a drilled board and works fine, except that the Reset-Button doesn't work as expected.

Pressing the RST-Button seems to crash the mcu but at least stops the output to the serial monitor after displaying a few "random characters".
No exception output.
Only disconnecting and reconnecting the usb cable recovers the serial output.
The reset pin isn't connected at all.
For testing I removed all modules (OLED, RTC, ADC, MicroSD) - same result ...

Also tested a ftdi232 for serial connection and powered the board from usb adapter - same result, except, that only disconnecting power restores serial output - restart of ftdi doesn't.
Tried to manually reset the wemos by connecting reset pin to GND - same result like pressing reset button..

Therefore I assume that pressing the reset button does crash the mcu ???
Is that possible?
How can i figure out what's going on?
User avatar
By rooppoorali
#96269 The WEMOS D1 Mini Pro board has a pull-up resistor on the reset pin, but if you are using a custom board, you may need to add your own pull-up resistor to ensure that the reset pin is not floating. If the reset pin is floating, it could cause the MCU to reset unpredictably or not at all.